`
369540808
  • 浏览: 197158 次
文章分类
社区版块
存档分类
最新评论

FZU 2104 (13.11.28)

 
阅读更多
Problem 2104 Floor problem

Accept: 376Submit: 433
Time Limit: 1000 mSecMemory Limit : 32768 KB

Problem Description

In this problem, we have f(n,x)=Floor[n/x]. Here Floor[x] is the biggest integer such that no larger than x. For example, Floor[1.1]=Floor[1.9]=1, Floor[2.0]=2.

You are given 3 positive integers n, L and R. Print the result of f(n,L)+f(n,L+1)+...+f(n,R), please.

Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 3 integers n, L and R (1≤n, L, R≤10,000, L≤R).

Output

For each test case, print the result of f(n,L)+f(n,L+1)+...+f(n,R) in a single line.

Sample Input

31 2 3100 2 100100 3 100

Sample Output

0382332

Source

“高教社杯”第三届福建省大学生程序设计竞赛


为高教杯复习而做,水题

直接贴AC代码:
#include<stdio.h>

int f(double x) {
    int i;
    for(i = 0; i <= 10000; i++)
        if(x >= i && x < i+1)
            break;
    return i;
}

int main() {
    int T;
    scanf("%d", &T);
    while(T--) {
        int n, l, r;
        int sum = 0;
        scanf("%d %d %d", &n, &l, &r);
        for(int i = l; i <= r; i++) {
            double num = n / i;
            sum += f(num);
        }
        printf("%d\n", sum);
    }
    return 0;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics